分享我所知道的

斐讯N1打造小型NAS三之armbian安装宝塔面板+可道云搭建文件管理器

一、安装宝塔面板

推荐安装5.9版本,一个是感觉6.x太花哨,安转的话还要改一些代码,二是5.9可以完美破解,相对来说好一点。

Centos安装命令:

yum install -y wget && wget -O install.sh http://download.bt.cn/install/install.sh && sh install.sh

Ubuntu/Deepin安装命令:

wget -O install.sh http://download.bt.cn/install/install-ubuntu.sh && sudo bash install.sh

Debian安装命令:

wget -O install.sh http://download.bt.cn/install/install-ubuntu.sh && bash install.sh

安装好面板后不要立即在后台开始安装WEB环境,因为PHP和Mysql缺乏依赖而不可能成功。

wget http://d.zmrbk.com/vps/libiconv-1.13.1.tar.gz
tar zxvf libiconv-1.13.1.tar.gz
cd libiconv-1.13.1
./configure -prefix=/usr/local --build arm-pc-linux
make & make install
ln -s /usr/local/lib/libiconv.so /usr/lib
ln -s /usr/local/lib/libiconv.so.2 /usr/lib/libiconv.so.2

如果1.13.1安装不上,可以试下1.16版本

wget http://d.zmrbk.com/vps/libiconv-1.16.tar.gz
tar zxvf libiconv-1.16.tar.gz
cd libiconv-1.16
./configure -prefix=/usr/local --build arm-pc-linux
make & make install
ln -s /usr/local/lib/libiconv.so /usr/lib
ln -s /usr/local/lib/libiconv.so.2 /usr/lib/libiconv.so.2

然后就可以进入宝塔后台安装WEB环境了

推荐安装Apache 2.4 / PHP 7.2 / Mysql 5.5,安装php5.x版本一般装不上,应该是没有适配arm的cpu。

mysql安装完后如果提示启动错误,需要在配置文件的  [mysqld]  添加以下内容,mysql才能启动
user=root  

apache安装完后可能会提示如下错误

httpd: Syntax error on line 130 of /www/server/apache/conf/httpd.conf: Cannot load modules/mod_ssl.so into server: /usr/lib/aarch64-linux-gnu/libssl.so.1.1: version `OPENSSL_1_1_1' not found (required by /www/server/apache/modules/mod_ssl.so)

我是直接修改配置文件,把LoadModule ssl_module modules/mod_ssl.so  屏蔽了,改为: #LoadModule ssl_module modules/mod_ssl.so

环境搭建好了,直接架设网站导入可道云源码就可以直接管理文件了。安装可道云部分详见  斐讯N1打造小型NAS六之armbian安装aria2

宝塔面板5.9版本破解教程可参阅  宝塔Linux面板5.9.0破解教程

赞(1)
未经允许不得转载:追梦人博客 » 斐讯N1打造小型NAS三之armbian安装宝塔面板+可道云搭建文件管理器
分享到: 更多 (0)