Blog

vestacp安装Zend Guard Loader教程

    在centos上安装的vestacp面板上安装Zend Guard Loader,vestacp默认的php版本是5.4.42 

首先根据自己的系统和php版本去zend官网下载文件

PHP5.6
32位:http://downloads.zend.com/guard/7.0.0/zend-loader-php5.6-linux-i386.tar.gz
64位:http://downloads.zend.com/guard/7.0.0/zend-loader-php5.6-linux-x86_64.tar.gz
PHP5.5
32位:http://downloads.zend.com/guard/7.0.0/zend-loader-php5.5-linux-i386.tar.gz
64位:http://downloads.zend.com/guard/7.0.0/zend-loader-php5.5-linux-x86_64.tar.gz
PHP5.4
32位:http://downloads.zend.com/guard/6.0.0/ZendGuardLoader-70429-PHP-5.4-linux-glibc23-i386.tar.gz
64位:http://downloads.zend.com/guard/6.0.0/ZendGuardLoader-70429-PHP-5.4-linux-glibc23-x86_64.tar.gz


其次解压文件,这里以centos6 x86安装的vestacp为例

wget http://downloads.zend.com/guard/6.0.0/ZendGuardLoader-70429-PHP-5.4-linux-glibc23-i386.tar.gz
tar xvfz ZendGuardLoader-70429-PHP-5.4-linux-glibc23-i386.tar.gz
cp ZendGuardLoader-70429-PHP-5.4-linux-glibc23-i386/php-5.4.x/ZendGuardLoader.so /usr/lib/php/modules/
 vi /etc/php.ini   #在php.ini的最后添加如下代码
添加到最后:
zend_extension= /usr/lib/php/modules/ZendGuardLoader.so
zend_loader.enable=1
zend_loader.disable_licensing=0
zend_loader.obfuscation_level_support=3
zend_loader.license_path=
service httpd restart

最后在ssh输入php -v查看是否安装成功


没有评论

Leave a Reply