Blog

Kloxo面板升级PHP版本

    kloxo还算不错的一个免费面板,虽然很多人说他后台界面丑,以前也爆过几次漏洞,但没有完美的程序,只要面板好用就行了,但由于kloxo原作者已挂,kloxo使用的都是老版本的程序,比如php还是5.2版本,现在有的网站程序要php5.3才能运行,所以只好手动给kloxo的php版本从5.2升级到5.3,因php5.2和php5.3差别较多,所以之前安装的一些东西可能会失效,例如ZendGuardLoader只支持php5.3以上,升级前做好备好。

    通过SSH登录服务器:
    分别执行:

移除掉PHP
yum remove php 
移除掉公共包
yum remove php-common
安装php 5.3
yum install php53 -y
安装mysql支持库
yum install php53-mysql -y

安装xml支持库
yum install php53-xml -y

安装gd支持库
yum install php53-gd -y

移除掉php-xcache
yum remove php-xcache

yum install php53-mbstring -y

如果不能连接SQL,可能需要
yum install php53-mysql -y

yum remove php 
yum remove php-common
yum install php53 -y
yum install php53-mysql -y
yum install php53-xml -y
yum install php53-gd -y
yum remove php-xcache
yum install php53-mbstring -y
yum install php53-mysql -y
yum httpd restart
service kloxo restart

没有评论

Leave a Reply